Jump to content
McKay Development
Argyl

Assigning proxy and new local address and port, client still showing public IP as my own.

Recommended Posts

So just trying to figure out if I'm dumb or if something is up. I'm updating my bot manager and since update doesn't use steam-client anymore I can't use .bind() which was working. See my attached image. Basically client is still returning my own localhost IP. Not the proxy one I'm setting.

 

 

 

440b5540cecc5e514d5acf595f9b0a37.png

Edited by Argyl

Share this post


Link to post
Share on other sites

So that was part of the issue. But now its not taking my proxies. Was connecting and logging in before and I tested them to make sure they are good to go.

{
  "message": "bind EADDRNOTAVAIL 173.208.103.160:8800",
  "stack": "Error: bind EADDRNOTAVAIL 173.208.103.160:8800\n    at internalConnect (net.js:824:18)\n    at defaultTriggerAsyncIdScope (internal/async_hooks.js:299:19)\n    at defaultTriggerAsyncIdScope (net.js:948
:9)\n    at processTicksAndRejections (internal/process/next_tick.js:74:9)",
  "errno": "EADDRNOTAVAIL",
  "code": "EADDRNOTAVAIL",
  "syscall": "bind",
  "address": "173.208.103.160",
  "port": 8800
}

That error crashes the process as well.

 

Any ideas?

Edited by Argyl

Share this post


Link to post
Share on other sites

So that was part of the issue. But now its not taking my proxies. Was connecting and logging in before and I tested them to make sure they are good to go.

{
  "message": "bind EADDRNOTAVAIL 173.208.103.160:8800",
  "stack": "Error: bind EADDRNOTAVAIL 173.208.103.160:8800\n    at internalConnect (net.js:824:18)\n    at defaultTriggerAsyncIdScope (internal/async_hooks.js:299:19)\n    at defaultTriggerAsyncIdScope (net.js:948
:9)\n    at processTicksAndRejections (internal/process/next_tick.js:74:9)",
  "errno": "EADDRNOTAVAIL",
  "code": "EADDRNOTAVAIL",
  "syscall": "bind",
  "address": "173.208.103.160",
  "port": 8800
}

That error crashes the process as well.

 

Any ideas?

 

173.208.103.160 is not an IP address assigned to any interface on your system. Is that a proxy IP? If so, just use the proxy option and don't set localAddress.

 

In my case, when I have updated steam-user to 4.2.0 or later, proxy setted by setHttpProxy stopped working fine, but when I rolled back to 3.21.1 it worked fine! But I need new version with proxy!

 

Please read the v4 release notes.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...