Jump to content


Photo

About HTTP Proxy

node.js node-steam-user

  • Please log in to reply
3 replies to this topic

#1 sarpdunno

sarpdunno

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 04 April 2019 - 03:28 PM

Hello,

i bought proxies on luminati.io. But always getting 'HTTP CONNECT 403 Bad Port' error on logOn.

 

My Code:

let user = new SteamUser({
  singleSentryfile: false,
  promptSteamGuardCode: false,
  dateDirectory: null,
  httpProxy: 'http://lum-customer-mycustomerid-zone-myzonename:[email protected]:22225'
});

user.logOn({
  accountName: 'test',
  password: 'test',
  rememberPassword: true
});

Debug:1a12e79820d86e4afdcb596df113eb55.png


Edited by sarpdunno, 04 April 2019 - 03:31 PM.


#2 Dr. McKay

Dr. McKay

    Developer

  • Administrator
  • 2,042 posts

Posted 04 April 2019 - 04:25 PM

Sounds like your proxies aren't permitting traffic on non-HTTP ports. Update to v4.6.0 and try adding "webCompatibilityMode": true to your constructor options and see if that helps.



#3 sarpdunno

sarpdunno

    Newbie

  • Member
  • Pip
  • 4 posts

Posted 04 April 2019 - 07:59 PM

Sounds like your proxies aren't permitting traffic on non-HTTP ports. Update to v4.6.0 and try adding "webCompatibilityMode": true to your constructor options and see if that helps.

Worked but always tries non-HTTP ports. So many timeout and errors iff server have port 443 or http port connected. 



#4 Dr. McKay

Dr. McKay

    Developer

  • Administrator
  • 2,042 posts

Posted 05 April 2019 - 02:29 AM

You'll need to be a little clearer.





Also tagged with one or more of these keywords: node.js, node-steam-user

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users