Jump to content
McKay Development
NoBody

Issue with webstorm

Recommended Posts

Hi,

I was trying to do some code with this npm package and everything was fine but webstorm still warns me that client.on() is undefined but it's working just fine but it is really annoying to have it there. Is there any way to fix that, I'm kinda new into this stuff so I don't know if I should change something in steam-user package to satisfy webstorm or just leave it be...

image.png.3d843622d3214fac6204f2dc7fb54333.pngimage.png.81c09f7c318f685194b315eb2f1299cb.png

Share this post


Link to post
Share on other sites

I try update and reinstall whole package and even try rebuild cache but I still get same message as before, webstorm is really confused, or is there maybe somethink what I'm doing wrong? maybe reinstall all packeges?

Share this post


Link to post
Share on other sites

So, after I made new project just with steam-user package it works, but after I installed all other modules that I needed it won't worked again so I dug deep into problem and I find out that problem was caused by @types/node module, @Dr. McKay any idea why?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...