Jump to content
McKay Development

Calling get getManifest returns error.


officialstrike
 Share

Recommended Posts

calling getManifest returns the error:
 

Error: Fail
    at Object.exports.eresultError (test\node_modules\steam-user\components\helpers.js:96:12)
    at SteamUser.<anonymous> (test\node_modules\steam-user\components\cdn.js:155:27)
    at SteamUser._handleMessage (test\node_modules\steam-user\components\messages.js:629:34)
    at SteamUser._handleNetMessage (test\node_modules\steam-user\components\messages.js:552:7)
    at SteamUser._processMulti (test\node_modules\steam-user\components\messages.js:676:8) {
  eresult: 2
} 

^ this seems to be an issue with "getCDNAuthToken" as when we're simply calling getManifest(730, 731, manifestid, (result) => { console.log(e) }) simply returns the error "eresult: 2"

Link to comment
Share on other sites

The version in node_modules/steam-user/package.json:
 

{
  "_args": [
    [
      "[email protected]",
      "D:\\VsCode\\JS\\test"
    ]
  ],
  "_from": "[email protected]",
  "_id": "[email protected]",
  "_inBundle": false,
  "_integrity": "sha512-ZrF2i0V5uwyQGRnHcfCvXCS3MrOR3WdN/VNoYIGqmW5Kbw7hSS3XTmGUW3JpLcjnsjzdiBCAOnIkoFvwtJuBuw==",
  "_location": "/steam-user",
  "_phantomChildren": {},
  "_requested": {
    "type": "version",
    "registry": true,
    "raw": "[email protected]",
    "name": "steam-user",
    "escapedName": "steam-user",
    "rawSpec": "4.20.0",
    "saveSpec": null,
    "fetchSpec": "4.20.0"
  },
  "_requiredBy": [
    "/",
    "/csgo-cdn"
  ],
  "_resolved": "https://registry.npmjs.org/steam-user/-/steam-user-4.20.0.tgz",
  "_spec": "4.20.0",
  "_where": "D:\\VsCode\\JS\\test",
  "author": {
    "name": "Alex Corn",
    "email": "[email protected]",
    "url": "https://www.doctormckay.com"
  },
  "bugs": {
    "url": "https://github.com/DoctorMcKay/node-steam-user/issues"
  },
  "dependencies": {
    "@bbob/parser": "^2.2.0",
    "@doctormckay/stdlib": "^1.11.1",
    "@doctormckay/steam-crypto": "^1.2.0",
    "adm-zip": "^0.4.13",
    "appdirectory": "^0.1.0",
    "binarykvparser": "^2.2.0",
    "bytebuffer": "^5.0.0",
    "file-manager": "^2.0.0",
    "lzma": "^2.3.2",
    "protobufjs": "^6.8.8",
    "steam-appticket": "^1.0.1",
    "steam-totp": "^2.0.1",
    "steamid": "^1.1.0",
    "vdf": "^0.0.2",
    "websocket13": "^2.1.3"
  },
  "description": "Steam client for Individual and AnonUser Steam account types",
  "devDependencies": {
    "steamcommunity": "^3.39.0",
    "wtfnode": "^0.8.4"
  },
  "engines": {
    "node": ">=8.0.0"
  },
  "homepage": "https://github.com/DoctorMcKay/node-steam-user",
  "keywords": [
    "steam",
    "steam client",
    "steam user"
  ],
  "license": "MIT",
  "name": "steam-user",
  "repository": {
    "type": "git",
    "url": "git+https://github.com/DoctorMcKay/node-steam-user.git"
  },
  "scripts": {
    "generate-enums": "node scripts/generate-enums.js",
    "generate-protos": "node scripts/generate-protos.js",
    "prepublishOnly": "node scripts/prepublish.js"
  },
  "version": "4.20.0"
}

^ version 4.20.0
see attached image that line 155 is indeed blank.

also node version is lts v14

image.png

Edited by officialstrike
Link to comment
Share on other sites

Here's my code, I should be getting the latest, can you check?

 user.getProductInfo(
        [730],
        [],
        true,
        (apps, packages, unknownApps, unknownPackages) => {
            const csgo = packages["730"].appinfo;
            const commonDepot = csgo.depots["731"];

            const manifest = commonDepot.manifests.public;
            user.getManifest(730, 731, manifest, "public", (err, data) => {
                console.log(err, data);
            });
        }
    );

also the error seems to be around "getCDNAuthToken", looking in to that further there seems to be:
appid: 730
depotId: 731
hostname: cache2-atl1.steamcontent.com

 

		this._send(SteamUser.EMsg.ClientGetCDNAuthToken, {
			app_id: appID,
			depot_id: depotID,
			host_name: hostname
		}, (body) => {

^ logging the body responds with:
"{ eresult: 2, token: null, expiration_time: null }"

Would you know why this happens? I can inspect skins, do everything, this just seems to fail.

Edited by officialstrike
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...